вторник, 2 февраля 2010 г.

CentOS 5.4 & Ruby

В CentOS 5.4 можно поставить Ruby только версии 1.8.5, ибо нету в репозитариях новее версии. Но если очень хочется, то можно поставитьболее новую версию Ruby, но из другого репозитария. Для этого нужно:
1. создать текстовый файл "ruby.repo" в /etc/yum.repod.d/

2. в файле написать текст:
[ruby]
name=ruby
baseurl=http://repo.premiumhelp.eu/ruby/
gpgcheck=0
enabled=0

3. а теперь просто выполнить комманду
yum --enablerepo=ruby install ruby
либо (если уже стоит старая версия)
yum --enablerepo=ruby update ruby

4. проверим версию Ruby коммандой
ruby -v
Отправить комментарий